Yes, I found that many friends will have this problem. When we use any Atomizer, Aegis Legend works fine. However, we can no longer use Aero Mesh Tank. You will find “No coil detected” on the screen, why? how to solve this problem.

Today I will tell you how to solve this problem.

1. Your coil head may be too tightly connected to the atomizer base, causing an error

A: Please reinstall the coil head. Don’t need to tighten too much, try again

2. If you still can’t solve the problem, then it may be that your coil head is broken.

A: Please find the spare coil head in the package and replace it. When you see the screen prompt “new coil” you can use it normally.

3. If you still can’t solve your problem, I think you need to consider your 510pin damage.

A: After removing other accessories, we can remove the 510pin separately. We can buy 510pin at the store and then replace it.

4. If your problem still cannot be solved, then you should contact Geekvape.

 

You May Also Like:

How to Use Geekvape Aegis Legend Kit – Manual

Related posts
I believe this issue is no stranger to most vapers. So what should we do when we encounter this problem? what...
Give a warning like NO ATOMIZER or CHECK ATOMIZER or NO COIL) Giving a like NO ATOMIZER or CHECK ATOMIZER...
Output short circuit Remind of "OHMS TOO HIGH" or "OHMS TOO LOW" Identify the problem caused by...
SMOK Mod Can't turn on Clicking 5 times in 2 seconds can't turn on Please check if the battery...

Sharing is caring!

Leave a Reply

Your email address will not be published. Required fields are marked *